Dependency

Linux Qtwallet

Dependency (16.04 Ubuntu)

Architecture: X68_64
OS 16.04 Ubuntu (64-bit)

1. sudo apt-get install qt5-default qt5-qmake qtbase5-dev-tools qttools5-dev-tools

2. sudo apt-get install build-essential libboost-dev libboost-system-dev

3. sudo apt-get install libboost-filesystem-dev libboost-program-options-dev libboost-thread-dev

4 sudo apt-get install libssl-dev libdb++-dev libminiupnpc-dev

5. sudo apt-get update

6. sudo apt-add-repository ppa:bitcoin/bitcoin

7. sudo apt-get update

8. sudo apt-get install libdb4.8-dev libdb4.8++-dev


Dependency (17.10 Ubuntu)

Architecture: X68_64
OS 17.10(artful) Ubuntu (64-bit)

1. sudo apt-get install build-essential

2. sudo apt-get install libssl-dev

3. sudo apt-get install libdb++-dev

4 sudo apt-get install libboost-all-dev

5. sudo apt-get install libqrencode-dev

6. sudo apt-get install libminiupnpc-dev





Dependency (18.04 Ubuntu)

Architecture: X68_64
OS 18.04 Ubuntu (64-bit)

1. sudo apt-get install build-essential

2. sudo apt-get install libssl-dev

3. sudo apt-get install libdb++-dev

4 sudo apt-get install libboost-all-dev

5. sudo apt-get install libqrencode-dev

6. sudo apt-get install libminiupnpc-dev

Windows Qtwallet

OS Windows (64-bit/32-bit)

macOSx Qtwallet

Dependency macOSx (Sierra & High Sierra)

If not properly run follow the below steps

Find the application in the Finder

Hold down the "control" key and click on the app icon of buxmac

Choose "Open" from the contextual menu that appears

When prompted with the message "AppName is from an unidentified developer. Are you sure you want to open it?" choose "Open"

The application will now have a permanent exception on that computer and can be opened normally.